PDA

View Full Version : Maintenence on SP Aria


fishuuuuu
12-27-2006, 03:36 AM
I've owned mine for about a month now. The clamps have a little give and dust all over the teeth, and the clamp bases are giving some wiggle whenever the tensioner is done with it.

How can I clean these two problems up, and what other things should I hit while I'm at it?

jj300
12-27-2006, 05:23 AM
for the clamps you can either disassemble them or just leave them open. You can take a toothbrush and dip it in alcohol or acedone and move it across the clamp teeth back and forth. After that, get a paper towel and clamp it to dry up the alcohol. The other option is soaking a shoe string with the same alcohol, hold it with your fingers and move it in between the clamp teeth

For the bases. Is the movement your seeing from flex btw the post of the clamp and the base or the actual base moves? If it is the base, I will let you know I had the same problem (asked 5 other aria owners and everyone said it didn't move). The base can be adjusted but NOTE WARNINING NOTE; they are super sensitive, one 1mm movement can totally make them even worse. I tried to adjust them but could not make them perfect. I have the instructions from sp but again I will warn you that it can make it worse rather than better.

fishuuuuu
12-27-2006, 03:23 PM
jj300, I checked out my machine more thoroughly after cleaning the clamps and it would seem that your observation is correct.

After securing the rest of the machine, I gave the locked turn-table base a couple of tugs and it wiggled quite a bit. In addition, one of the clamp posts gives some wiggle room.

jj300
12-27-2006, 04:47 PM
shoot me an e-mail

fishuuuuu
12-27-2006, 05:29 PM
shoot me an e-mail

I don't have your e-mail jj300, mine is nmk000@gmail.com.