PDA

View Full Version : Dissapointed with TW online oredering


Tahsin1982
06-27-2011, 06:28 AM
I tried so many times to order the Prince Renegade Black/Green Men's Shoes last night the form does not even work!

After I fill in the contact information it never goes to the shipping information page at all. I had ordered from TW the yonex pro grip last year and there was no problem but now I just dont get it.

I even mailed TW last night and upto now I still did not get a reply from them.

I am very disjointed and dont think I will be purchasing from you guys anymore in the future!

PeterPanda
06-27-2011, 12:27 PM
I think you were just a unlucky one.

Fuji
06-27-2011, 12:48 PM
I tried so many times to order the Prince Renegade Black/Green Men's Shoes last night the form does not even work!

After I fill in the contact information it never goes to the shipping information page at all. I had ordered from TW the yonex pro grip last year and there was no problem but now I just dont get it.

I even mailed TW last night and upto now I still did not get a reply from them.

I am very disjointed and dont think I will be purchasing from you guys anymore in the future!

About the ordering form, sometimes the site goes down when they are updating it. It happens to me every few months. It's not really TW's fault; there isn't anything they can do about it. :p

-Fuji

Lsmkenpo
06-27-2011, 01:30 PM
Maybe you need to clear out the cookies in your browser.

EaGamer
06-27-2011, 08:20 PM
I just made a large order last Thursday so do some of the things suggested by other people here. I did not have a problem with my order or contacting TW through email when a minor issue arose with the tracking number.

StanW
06-28-2011, 12:44 AM
Call/Email them! They always reply quickly.

Tahsin1982
06-28-2011, 06:58 AM
Well I did clear my cache and cookies and even tried on different browser such as chrome. firefox and ie and all are upto date. And I even tried yesterday to see if the server is ok and I still cant seem to go to the shipping info area after I fill up the personnel information. Its weird cause I ordered before and did not have any problem.

I know there is a postal strike going on in Canada now so I dont know is it because of that TW did something to the form temporarily for the canadians but the customer service people also has no idea what is going on with their server as well/

Anyway the matter is clear now think in the future Ill just email them.

Centryx
06-28-2011, 07:07 AM
well you tried to make an order sunday night so I doubt they have someone on staff that late I doubt any online retailer will have someone pick up the phone on a sunday nite. you could always call them during the day they have been great resolving issues.

Setmatch45
06-28-2011, 09:26 AM
I am suprised your having a problem. I just tried to order the same pair of shoes in a size 13 and had no problem. Try calling them they are really great to work with.

PeterFig
06-28-2011, 09:59 AM
Well I did clear my cache and cookies and even tried on different browser such as chrome. firefox and ie and all are upto date. And I even tried yesterday to see if the server is ok and I still cant seem to go to the shipping info area after I fill up the personnel information. Its weird cause I ordered before and did not have any problem.

I know there is a postal strike going on in Canada now so I dont know is it because of that TW did something to the form temporarily for the canadians but the customer service people also has no idea what is going on with their server as well/

Anyway the matter is clear now think in the future Ill just email them.

They don't use Canada Post for their shipping so I doubt that's anything to do with your inability to order.

To be more clear it would be helpful it would be good to describe or provide a screenshot of what actually happens when you fill in your personal info and can't proceed. Do you get an error? Is the shipping info greyed out? etc... :)

PeterFig
06-28-2011, 10:04 AM
OK - just tried to order same shoes as you wanted to .. and I'm in Canada ... had no issues at all. Using Safari.

Screenshot:
http://f.cl.ly/items/1X1m392k422q2A1w1L3G/tw.jpg

Tahsin1982
06-28-2011, 11:24 AM
http://img860.imageshack.us/img860/1181/errorfhk.jpg (http://imageshack.us/photo/my-images/860/errorfhk.jpg/)

Uploaded with ImageShack.us (http://imageshack.us)

Here you go. The only error they show is the postal code which as I said before is the same one I used in the past to purchase and had no problem and if I leave the company form part blank it just returns back to this page and it gets fraustrating cause the form does not even indicate which part you might have typed wrongly.

Can you see if you can go to the next page when you click checkout? I am running a full scan on my computer with MC afee just to make sure I dont have any virus or something that might be causing this problem.

PeterFig
06-28-2011, 12:14 PM
http://img860.imageshack.us/img860/1181/errorfhk.jpg (http://imageshack.us/photo/my-images/860/errorfhk.jpg/)

Uploaded with ImageShack.us (http://imageshack.us)

Here you go. The only error they show is the postal code which as I said before is the same one I used in the past to purchase and had no problem and if I leave the company form part blank it just returns back to this page and it gets fraustrating cause the form does not even indicate which part you might have typed wrongly.

Can you see if you can go to the next page when you click checkout? I am running a full scan on my computer with MC afee just to make sure I dont have any virus or something that might be causing this problem.

OK - I think to solve your problem try selecting "Canada" from the dropdown again on the Shipping Address side... but don't choose the first option "CANADA" all in caps, instead scroll down till you find it listed alphabetically as "Canada" <-- lowercase. Let me know if that works :)

PeterFig
06-28-2011, 12:20 PM
And just in case TW website guys are looking at this ... there is an error in your code in the Shipping Address country dropdown. Your default "CANADA" selection (the one that's all caps at the top) is coded wrong. In the code the value for Canada is actually Belgium!:

<OPTION VALUE="BELGIUM" SELECTED>CANADA

:)

AlpineCadet
06-28-2011, 12:35 PM
TW has always been amazing when it comes to replies, and I've never had any issues with them because they're just too good at this.

Tahsin1982
06-28-2011, 12:39 PM
Peter your right it worked and yes TW should look into this problem as a lot of people from Canada may select CANADA from the dropdown and face the same problem.

Thanks Peter

PeterFig
06-28-2011, 12:44 PM
Peter your right it worked and yes TW should look into this problem as a lot of people from Canada may select CANADA from the dropdown and face the same problem.

Thanks Peter

I'm glad it worked for you. It's something for TW to look into for sure - but I think it only happens if you perform a specific sequence of steps - so just a little programming bug. Every site out there has them - so no big deal. It's not intentional on TW's part and they're great in their customer service so always give them a quick call if in the future you have any issues with anything.

Fuji
06-28-2011, 01:00 PM
I'm from Canada as well, and I just did some ordering the other night and it worked absolutely fine. :)

I used FireFox Btw! :)

-Fuji

PeterFig
06-28-2011, 01:13 PM
I'm from Canada as well, and I just did some ordering the other night and it worked absolutely fine. :)

I used FireFox Btw! :)

-Fuji

Yes, it works most of the time - it's not a user/browser/OS type of bug as far as I can tell. It's a programming bug on the site when it fills in the Shipping country from either a previous visit to the page, or maybe from passing it from the billing address portion or something like that. It only seems to happen after a specific set of actions on the site so as a result not everyone experiences problems. Didn't have time to retrace it all but I'm sure the good people at TW will find the issue :)

TW Staff
06-28-2011, 01:18 PM
Peter, et al., thank you for all the information on this. I'll most certainly pass it along to those that can take care of it.

Cheers,

Spencer, TW.