PDA

View Full Version : My problem with TT+


HaNbAnG
10-02-2006, 10:51 PM
I just bought TT+ and currently use pressureless balls for the machine.
I was wondering if any of you have same problem as I do.
When I use the machine, some of the balls shoot out very unusual.
It shoots sideways with loud nois or it shoots inside the box itself.
Any advise on how to fix the problem?
Should I ask for exchange?

SpinItIn
10-03-2006, 03:21 AM
You might want to check the alignment of the upper & lower rubber wheels. I had a minor problem with my machine (a demo unit) when I got it - balls would sometimes come out with some sidespin or even clip the the housing on the way out. When I took the cover off to investigate I found the upper wheel was loose on the shaft. Their tech support couldn't give me a setup dimension they use for assembly so I just verified that the lower wheel was centered in the housing slot and made the upper wheel match. BTW, the setscrews that hold the wheels on the shafts are much easier to reach if you take the top cover off - doing so exposes everything inside the machine for easy access.

I would have been more disappointed if I had this problem with a brand new machine, but I can see it getting by them on a demo unit. Their tech support was pretty helpful when I called so I'm still a satisfied customer.

billyboybeacon
10-03-2006, 07:05 AM
call sports tutor b4 you use again..they have been awesome answering any questions I have had...you have something loose in there!!

Chipenstein
10-03-2006, 11:51 PM
That's not right...mine's never done that. Better give them a shout.