Extremely irritating board bug, please advise

Discussion in 'Talk Tennis Updates' started by not_federer, Jan 19, 2012.

  1. not_federer

    not_federer Rookie

    Joined:
    Jun 1, 2010
    Messages:
    301
    I'm not sure if this is the right board for my problem but here goes.

    Every time I try to log in and reply I encounter heavy resistance. Here's what happens:

    1 - Hit reply
    2 - enter "not_federer"
    3 - type password, hit enter
    4 - read the message "Thank you for logging in, not_federer!"
    5 - then it takes me back to the login page.

    EVERY
    SINGLE
    TIME!

    Why?

    It's finicky and not entirely consistent. For example, I'm writing this post without any resistance. Also, if I go into a thread and hit the reply button on the top left of the thread, as opposed to as the bottom, it works - but only after logging in several times. The whole thing is madness and makes no sense.

    Is this a bug? Am I doing it wrong? Is it my account settings, am in being punished, what? I'm really curious.
     
    #1
  2. Bartelby

    Bartelby G.O.A.T.

    Joined:
    Nov 14, 2005
    Messages:
    12,539
    Yes, it does do this.

    Tick the box in the log in about remembering you and it can be avoided.
     
    #2
  3. JoelDali

    JoelDali G.O.A.T.

    Joined:
    Mar 30, 2009
    Messages:
    10,573
    Hit the refresh button when you get kicked to the next login prompt AFTER typing in your credentials.

    If on a home PC use Firefox which caches creds nicely.
     
    #3
  4. hcb0804

    hcb0804 Hall of Fame

    Joined:
    Jul 18, 2009
    Messages:
    2,286
    It does this to me too and really p****s me off.
    How about a fix TW?
     
    #4
  5. VaththalKuzhambu

    VaththalKuzhambu Rookie

    Joined:
    Sep 24, 2010
    Messages:
    141
    This happens to me EVERY time I login.

    And I spent quite some time trying to fix my Firefox and Chrome while the bug was with TalkTennis.

    Grrrrr.
     
    #5
  6. MethodTennis

    MethodTennis Hall of Fame

    Joined:
    Mar 23, 2008
    Messages:
    3,617
    This does my head in!
     
    #6
  7. julian

    julian Hall of Fame

    Joined:
    Dec 20, 2006
    Messages:
    3,246
    Location:
    Bedford,Massachusetts,US
    #7
  8. EclipseRydr97

    EclipseRydr97 Rookie

    Joined:
    Feb 7, 2006
    Messages:
    315
    Location:
    Irvine, CA
    yeah it does it to me too, as was suggested, after i enter my password and hit enter, asks me for login info and i just hit refresh again and viola, kind of annoying but what can you do until there's a fix
     
    #8
  9. WhiskeyEE

    WhiskeyEE Legend

    Joined:
    Jan 26, 2008
    Messages:
    5,308
    Can you please fix this? This has been going on for years and I can't understand why it hasn't been addressed. It doesn't happen on any other forum I've been to.
     
    #9
  10. syke

    syke Professional

    Joined:
    Jan 4, 2012
    Messages:
    1,356
    Nothing beats the darn tapatalk pop up every time you go to a new page on the iPhone. It stinks, please remove it!

    It was much better before. Tapatalk is a POS app
     
    #10
  11. cghipp

    cghipp Professional

    Joined:
    Jun 10, 2006
    Messages:
    1,282
    I have this problem, too. (Yes, even if I check "remember me.") I sometimes see it on another board that uses the same software.

    Anyway, here's a temporary, if unsatisfying fix: After you log in using hte login box at the top of the page, and it takes you to the board page that clearly does NOT show you as logged in, click on one of the board sections anyway (such as "Talk Tennis Updates). After you do that, you'll see that you ARE logged in - your "User CP" page is available.

    I don't know why, but that first "landing page" will not show you as logged in even if you are, and navigating to another area of the board immediately after that fixes the problem for me.
     
    #11
  12. Pacific lefty

    Pacific lefty Rookie

    Joined:
    Nov 3, 2011
    Messages:
    272
    Location:
    Europe
    Happens to me all the time...
     
    #12
  13. cluckcluck

    cluckcluck Hall of Fame

    Joined:
    Apr 29, 2010
    Messages:
    2,244
    Location:
    Between the baseline and netcord.
    Yep me too. I call it the 'infinite loop of login death'
     
    #13
  14. Sentinel

    Sentinel Bionic Poster

    Joined:
    Jan 21, 2008
    Messages:
    30,248
    Location:
    Somewhere over the rainbow
    1. Use the login textbox that comes on top right, not the box that comes in the center of the page.

    2. Click on Keep me logged in/ remember me.
     
    #14
  15. BeHappy

    BeHappy Hall of Fame

    Joined:
    Aug 24, 2007
    Messages:
    4,789
    It seems to be getting worse.
     
    #15
  16. jaggy

    jaggy G.O.A.T.

    Joined:
    Jun 8, 2006
    Messages:
    12,716
    Location:
    Carrboro, NC
    It only happens to me at work but does happen every time
     
    #16
  17. PrinceMoron

    PrinceMoron Hall of Fame

    Joined:
    May 1, 2009
    Messages:
    3,165
    Why not try the French Open Ap. and then you realise the TWH forum is brilliant?

    Even has match terminated instead of completed matches. So you think it has been rained off.

    Crashes all the time and there is a stuuuuuuuupid link to the shop eveeeeeeeery time you open the ap. Aaaaaaaaaaaaaaaaaaaaargh!!!!!!!!!
     
    #17
  18. Swissv2

    Swissv2 Hall of Fame

    Joined:
    Oct 19, 2005
    Messages:
    2,491
    Location:
    Tennis Courts!
    This happens to me too, but I have found a simple temporary solution.

    1. Login
    2. Press Refresh button

    It will log you in properly after that. Unfortunately, you have to do this process each time you visit the website.
     
    #18
  19. Surecatch

    Surecatch Semi-Pro

    Joined:
    Aug 22, 2005
    Messages:
    631
    Very glad to see this covered here......I logged in for the first time in several years and it's happened repeatedly as I've tried to reply to other posts.

    Weird and aggravating, but not enough so to keep me away. I love it here....the wealth of knowledge is amazing and it feeds my tennis obsession, so it all gooood.

    :)
     
    #19
  20. Raul_SJ

    Raul_SJ Professional

    Joined:
    May 19, 2011
    Messages:
    1,326
    Location:
    San Jose, California
    This needs to be fixed.

    Users should not need to workaround this bug.

    It needs to be fixed.
     
    #20
  21. nikdom

    nikdom Hall of Fame

    Joined:
    Mar 10, 2009
    Messages:
    4,725
    Location:
    Tennisville
    I think I know what the issue is.

    It's not the checking the 'Remember Me' check box. All that does is create a cookie on the user's browser. If my guess is correct, the problem is on the server side.

    More than likely TW is using multiple servers for hosting the vBulletin PHP application that powers these boards. These servers are usually placed behind what's called a load-balancer :- meaning that incoming HTTP requests are routed to one or more servers. When a login request goes to a server, that individual server creates what's called a "Session" (a server side cookie) for that user ON THAT server. These "sessions" are usually not transferred between the different servers (unless TW does something more complicated called session-replication in which case the replication is slow)

    You can see right away what the problem is then. Server A logs you in and creates a session on that server and redirects your browser to the next page. Unfortunately, if the load balancer is not doing what's called a "sticky session", i.e sticking your requests to that one server, this redirect request goes to another server B behind the same load balancer. Server B has no clue you have logged in (since it has no session for you) and asks that you log in again. This process can repeat if there are multiple servers and the load balancer is not doing sticky sessions.

    The reason I think the load balancer is the problem is because you can confirm it by doing this -

    1. Enter your login information and hit enter
    2. Now you're back to a page where you're asked again for your login information or you are on one of the forum pages but it does not show you as logged in at the top.
    3. Now keep refreshing the forum page. Eventually you'll find that it shows you as logged in.

    What's happened is by refreshing you're sending multiple requests for the page and eventually the balancer sent one to one of the servers which DOES have a session for you.

    I'm happy to offer any assistance if one of the mods wants to contact me. You would need to get in touch with your hosting/IT staff and have them resolve the round-robin load balancer issue with sticky sessions.

    tl;dr version -

    - Refresh the page (or keep doing so) until you see you're logged in.
    - Problem is a technical one on the Warehouse servers which is not debilitating but most likely the one described in detail above
     
    Last edited: Jan 6, 2013
    #21
  22. PeteD

    PeteD Hall of Fame

    Joined:
    Jan 28, 2005
    Messages:
    2,397
    Location:
    The Commonwealth (of PA)
    The issue and the f5 solution have been around for years.
     
    #22
  23. Lakers4Life

    Lakers4Life Hall of Fame

    Joined:
    Jul 13, 2009
    Messages:
    3,638
    Location:
    Laker Land
    Maybe you also need to remember password in your browser. I access TT-TW on various browsers throughout the day. Android Tablet, Ipad, IE8, IE7, Fiefox, Chrome, etc. No problems at all "remembering me".
     
    #23
  24. Sabratha

    Sabratha G.O.A.T.

    Joined:
    Jun 6, 2012
    Messages:
    12,079
    Location:
    Australia
    This has happened to me, found the "remember me" part worked.
     
    #24
  25. Cormorant

    Cormorant Professional

    Joined:
    Jun 28, 2011
    Messages:
    1,222
    That was helpful, and it only took me a year and a half to get an answer for this little problem.
     
    Last edited: Jan 15, 2013
    #25
  26. TW Staff

    TW Staff Administrator

    Joined:
    Jan 21, 2004
    Messages:
    24,302
    Location:
    Tennis-Warehouse.com
    This also happens to the admin as well, so it is not just a user error. I find, like the other users mentioned, pushing the "refresh" button after your log in, takes you to the correct log in page. In the future if you have any problems or questions and wish them to be answered or addressed quicker by the admin, please post in TW Questions/Comments section and then we will be able to help!

    TW Staff
     
    #26
  27. julian

    julian Hall of Fame

    Joined:
    Dec 20, 2006
    Messages:
    3,246
    Location:
    Bedford,Massachusetts,US
    Which one is the "refresh button"?

    Which one is the "refresh button"?
    It is a serious qurstion
     
    #27
  28. Lakers4Life

    Lakers4Life Hall of Fame

    Joined:
    Jul 13, 2009
    Messages:
    3,638
    Location:
    Laker Land
    The circle with the Arrow on most browsers or the "Pieces" Arrows. On PC Keyboards "F5".
     
    #28
  29. diredesire

    diredesire Super Moderator

    Joined:
    Mar 16, 2004
    Messages:
    6,712
    You can alternately use Ctrl + R or Command + R depending on which platform you're running.

    I tried to get in touch with the technical admin of the board to check some code issues on the board, but still haven't heard back. This is an issue with vBulletin, and isn't strictly limited to our board. Bummer.
     
    #29
  30. Chemist

    Chemist Rookie

    Joined:
    Dec 4, 2012
    Messages:
    344
    Location:
    Near a tennis court
    It has happened to me too. One easy solution is to check the "Remember Me" next to User Name to save your username and password. So everytime you click Talk Tennis, you are automatically logged in. It worked for me:)
     
    #30

Share This Page