Gamma clamp clicking sound...

myke232

Rookie
I have the Gamma X-2. Every time I release the tension on the drop weight one of my clamps makes a clicking noise. It doesn't seem to be slipping when this happens, but it doesn't sound right. The other clamp doesn't make this noise at all. Any ideas?
 

struggle

Legend
OK sorry, I don't know then :oops:
Are you able to take those clamps apart and see if any of the plastic is cracked?
I had a glide aluminum clamp on my 5800ELS that literally shattered behind the adjustment screw knob.
I had the bearings fall apart in the clamps on my 6004. Warranty was up but John took care of me. After that, the diamond
dust plates, or whatever you may call them just fell off. Once again, John took care of me. So i think i have parts from 3 different sets (2 at least...). Should be ok for awhile unless one part fails which i don't have a double of.
 

Gamma Tech

Professional
myke232, Hummmmm not sure what the clicking is, but we'll figure it out. If you can email me a short video I might see/hear what the problem is. Send the video to cad@gammasports.com Once we know what the problem is, we'll post back here.
 

myke232

Rookie
myke232, Hummmmm not sure what the clicking is, but we'll figure it out. If you can email me a short video I might see/hear what the problem is. Send the video to cad@gammasports.com Once we know what the problem is, we'll post back here.
Ok, thank you. I sent an email regarding the issue to gamma (the only address I could find was the 'sales' one). It may be a while though before I can make a video as I don't have any racquets that I can string up right now.
 

TypeRx

Semi-Pro
That has happened to me a few times (same stringer and clamps) and it appeared to be because I had the clamps on a bit too tight for the string I was working with. After loosening the adjustment knob about a half turn counter-clockwise, the clicking went away.
 

myke232

Rookie
That has happened to me a few times (same stringer and clamps) and it appeared to be because I had the clamps on a bit too tight for the string I was working with. After loosening the adjustment knob about a half turn counter-clockwise, the clicking went away.
Interesting, thanks. But I've used it on and adjusted it for 15g 16g and 17g strings and always for the clicking... so I don't think that's it.
 

Irvin

Talk Tennis Guru
Interesting, thanks. But I've used it on and adjusted it for 15g 16g and 17g strings and always for the clicking... so I don't think that's it.
If it just one clamp clicking have your tried to disassemble the clamps and swap parts between the two to I’d the source?

EDIT: Although you don’t have a racket to string does the clicking occur when you just clamp and release a string? If so you could break out your iPhone and make a video for @Gamma Tech.
 
Top